summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Dauvergne <bdauvergne@entrouvert.com>2008-03-14 14:40:10 +0000
committerBenjamin Dauvergne <bdauvergne@entrouvert.com>2008-03-14 14:40:10 +0000
commit0eba1f41a554b8b5326f1cb8bf03d88956062f64 (patch)
treeed26ec67f1453bd43a3d2320d6475ecaa9f49934 /configure.ac
parentc9f7e1e74787939d6943b60e4a8b92afc4d6b19a (diff)
downloadlasso-0eba1f41a554b8b5326f1cb8bf03d88956062f64.tar.gz
lasso-0eba1f41a554b8b5326f1cb8bf03d88956062f64.tar.xz
lasso-0eba1f41a554b8b5326f1cb8bf03d88956062f64.zip
* configure.ac: remove generation of php5/Makefile, it does nothing. add
detection of pre-4.1.3 gcj versions. add bindings/python/tests/Makefile in commented AC_OUTPUT code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2c6478d8..02e7a115 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,13 +280,20 @@ if test "x$JAVAH" = "xgcjh" || test "x$JAVAH" = "xgjavah" ; then
fi
dnl If the java compiler is the GNU Java Compiler.
-if test "x$JAVAC" = "xgcj -C"; then
+if echo "$JAVAC" | grep -q "gcj"; then
changequote(<<, >>)dnl
- JAVA_VERSION=`$JAVAC --version 2>&1 | $SED -ne 's/gcj ([^)]*) \([^ ]*\).*/\1/p' 2>/dev/null`
+ JAVA_VERSION=`$JAVAC --version 2>&1 | $SED -ne 's/gcj[^[:blank:]]* ([^)]*) \([^ ]*\).*/\1/p' 2>/dev/null`
+ MAJOR=`echo $JAVA_VERSION | sed 's/.*[^[:digit:]]\?\([[:digit:]]\+\)\.[[:digit:]]\+\.[[:digit:]]\+/\1/'`
+ MINOR=`echo $JAVA_VERSION | sed 's/.*[^[:digit:]]\?[[:digit:]]\+\.\([[:digit:]]\+\)\.[[:digit:]]\+/\1/'`
+ RELEASE=`echo $JAVA_VERSION | sed 's/.*[^[:digit:]]\?[[:digit:]]\+\.[[:digit:]]\+\.\([[:digit:]]\+\).*/\1/'`
changequote([, ])dnl
-
dnl Byte-compiled .class file
- JAVAC_FLAGS="-fsource=1.4 -ftarget=1.4"
+ if test $MAJOR -gt 4 -o \( $MAJOR -eq 4 -a $MINOR -gt 1 \) -o \( $MAJOR -eq 4 -a $MINOR -eq 1 -a $RELEASE -ge 3 \); then
+ JAVAC_FLAGS="-fsource=1.4 -ftarget=1.4"
+ fi
+ unset MAJOR
+ unset MINOR
+ unset RELEASE
dnl Checking for jni.h if gcj is the java interpreter.
AC_CHECK_HEADERS([jni.h], [], [JAVA_VERSION=""])
CLASSPATH_OPT="--classpath"
@@ -916,7 +923,6 @@ lasso/xml/id-wsf-2.0/Makefile
lasso/xml/ws/Makefile
perl/Makefile
php/Makefile
-php5/Makefile
python/Makefile
swig/Makefile
swig/wsf-support.i
@@ -952,6 +958,7 @@ win32/nsis/python.nsi
dnl AC_OUTPUT([
dnl bindings/Makefile
dnl bindings/python/Makefile
+dnl bindings/python/tests/Makefile
dnl bindings/java/Makefile
dnl bindings/php5/Makefile
dnl ])