summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Laniel <dlaniel@entrouvert.com>2008-09-16 13:02:47 +0000
committerDamien Laniel <dlaniel@entrouvert.com>2008-09-16 13:02:47 +0000
commit09bbae229e0b790e9435578630dc8dc068d159d2 (patch)
tree8a70c5a319b28c5de60e95d3c633c7123cf46dba /configure.ac
parent9ed0670e48665f590eda685e0cfebf8c4cadb8fb (diff)
downloadlasso-09bbae229e0b790e9435578630dc8dc068d159d2.tar.gz
lasso-09bbae229e0b790e9435578630dc8dc068d159d2.tar.xz
lasso-09bbae229e0b790e9435578630dc8dc068d159d2.zip
enable optimisation flag when not debugging
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e2ced78..a6d4e814 100644
--- a/configure.ac
+++ b/configure.ac
@@ -842,6 +842,7 @@ if test "z$enable_debugging" = "zyes" ; then
AM_CFLAGS="$AM_CFLAGS -O0 -g -Wall -Wextra -Werror -Wno-missing-field-initializers"
else
enable_debugging=no
+ AM_CFLAGS="$AM_CFLAGS -O2"
fi
AM_CONDITIONAL([DEBUGGING],[test "x$enable_debugging" = "xyes"])
AC_MSG_RESULT($enable_debugging)