summaryrefslogtreecommitdiffstats
path: root/bindings/perl/Makefile.PL
diff options
context:
space:
mode:
authorBenjamin Dauvergne <bdauvergne@entrouvert.com>2010-01-29 00:43:53 +0000
committerBenjamin Dauvergne <bdauvergne@entrouvert.com>2010-01-29 00:43:53 +0000
commit8b06d7c1ae1cd2a1ffeab9b0314dcd34828e4b5e (patch)
tree3ecda76e01b13c4327b656eb0ba9830fe95bc03a /bindings/perl/Makefile.PL
parentb2f07a064046d6dfbf47d39ea5c6eb130df595cf (diff)
downloadlasso-8b06d7c1ae1cd2a1ffeab9b0314dcd34828e4b5e.tar.gz
lasso-8b06d7c1ae1cd2a1ffeab9b0314dcd34828e4b5e.tar.xz
lasso-8b06d7c1ae1cd2a1ffeab9b0314dcd34828e4b5e.zip
Binding perl: many improvements
* handle GHashTable of strings and objects. * report errors with 'croak' as a Lasso::Error object. * add more basic tests. * for string arguments, convert undef to NULL, and croak if function does not accept NULL. * fix library paths in Makefile.PL.
Diffstat (limited to 'bindings/perl/Makefile.PL')
-rw-r--r--bindings/perl/Makefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/bindings/perl/Makefile.PL b/bindings/perl/Makefile.PL
index 0a46d2e0..ddcc0067 100644
--- a/bindings/perl/Makefile.PL
+++ b/bindings/perl/Makefile.PL
@@ -21,7 +21,7 @@ WriteMakefile(
PREREQ_PM => {}, # e.g., Module::Name => 1.1
($] >= 5.005 ? ## Add these new keywords supported since 5.005
( AUTHOR => 'Benjamin Dauvergne <bdauvergne@entrouvert.com>') : ()),
- LIBS => ["-L$TOP_SRCDIR/lasso/.libs -llasso"], # e.g., '-lm'
+ LIBS => "-L../../lasso/.libs -llasso", # e.g., '-lm'
DEFINE => '', # e.g., '-DHAVE_SOMETHING'
INC => "-I. -I$SRCDIR -I$SRCDIR/../.. -I$TOP_BUILDDIR $CFLAGS", # e.g., '-I. -I/usr/include/other'
# Un-comment this if you add C files to link with later: