summaryrefslogtreecommitdiffstats
path: root/bindings/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Dauvergne <bdauvergne@entrouvert.com>2010-01-25 23:47:56 +0000
committerBenjamin Dauvergne <bdauvergne@entrouvert.com>2010-01-25 23:47:56 +0000
commitc312a6f91a1c437dad7ce9a5179c9cd655a0fccd (patch)
tree140184f2753c065f2d6fe5cce0558416477d4858 /bindings/Makefile.am
parentc3c44c2371101c9664a4b61e816c3096d9005c80 (diff)
downloadlasso-c312a6f91a1c437dad7ce9a5179c9cd655a0fccd.tar.gz
lasso-c312a6f91a1c437dad7ce9a5179c9cd655a0fccd.tar.xz
lasso-c312a6f91a1c437dad7ce9a5179c9cd655a0fccd.zip
Bindings: add a new perl binding using the new binding infrastructure
* XS files is autogenerated using bindings/binding.py model of the Lasso API. All constants are in the Lasso::Constants package, the LASSO_ prefix is removed. All classes are now Lasso::ClassName, field accessor also serves as setters, i.e you can do this: $name_id = Lasso::Saml2NameID::new(); $name_id->content('coin'); print $name_id->content; Is still missing: - a lot of test files, - support for hashtables, - and throwing exceptions when return code is non-zero.
Diffstat (limited to 'bindings/Makefile.am')
-rw-r--r--bindings/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
index 2c7c594b..fde10816 100644
--- a/bindings/Makefile.am
+++ b/bindings/Makefile.am
@@ -9,6 +9,9 @@ endif
if JAVA_ENABLED
SUBDIRS += java
endif
+if PERL_ENABLED
+SUBDIRS += perl
+endif
CLEANFILES = bindings.pyc lang_java.pyc lang_python.pyc lang_php5.pyc \
utils.pyc lang_php5_helpers/__init__.pyc lang_php5_helpers/php_code.pyc \