summaryrefslogtreecommitdiffstats
path: root/bindings/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Dauvergne <bdauvergne@entrouvert.com>2008-09-12 13:57:27 +0000
committerBenjamin Dauvergne <bdauvergne@entrouvert.com>2008-09-12 13:57:27 +0000
commit0e706e6598cbdbf0dae5ef74a0cb4c206f590b82 (patch)
treefbcd53ed505e53e79fdfab5ebb532ed69d44980c /bindings/Makefile.am
parentae1f6a297c62a7fd0bcf33865629eb21ef1e87d5 (diff)
downloadlasso-0e706e6598cbdbf0dae5ef74a0cb4c206f590b82.tar.gz
lasso-0e706e6598cbdbf0dae5ef74a0cb4c206f590b82.tar.xz
lasso-0e706e6598cbdbf0dae5ef74a0cb4c206f590b82.zip
* Select bindings in bindings/Makefile not in bindings/*/Makefile.
Diffstat (limited to 'bindings/Makefile.am')
-rw-r--r--bindings/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
index c49f50f9..2c7c594b 100644
--- a/bindings/Makefile.am
+++ b/bindings/Makefile.am
@@ -1,5 +1,14 @@
MAINTAINERCLEANFILES = Makefile.in
-SUBDIRS = python php5 java
+SUBDIRS =
+if PYTHON_ENABLED
+SUBDIRS += python
+endif
+if PHP5_ENABLED
+SUBDIRS += php5
+endif
+if JAVA_ENABLED
+SUBDIRS += java
+endif
CLEANFILES = bindings.pyc lang_java.pyc lang_python.pyc lang_php5.pyc \
utils.pyc lang_php5_helpers/__init__.pyc lang_php5_helpers/php_code.pyc \