summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRomain Chantereay <rchantereau@entrouvert.com>2004-08-05 10:32:48 +0000
committerRomain Chantereay <rchantereau@entrouvert.com>2004-08-05 10:32:48 +0000
commit9fe13851e59dd584617cf79822fe4ba2bcb058e3 (patch)
tree8c6d9e6fc033e3c3b246dc0d35cedc3a0bc1295b /Makefile.am
parent33ebd74c07908e1365847fafd268c1e463e02a07 (diff)
downloadlasso-9fe13851e59dd584617cf79822fe4ba2bcb058e3.tar.gz
lasso-9fe13851e59dd584617cf79822fe4ba2bcb058e3.tar.xz
lasso-9fe13851e59dd584617cf79822fe4ba2bcb058e3.zip
Use of conditional subdirectories.
This permit automake to automaticaly define a correct DIST_SUBDIRS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a7dcc20a..ba6ef000 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,11 @@
-SUBDIRS = lasso docs @SD_LANG@ tests
+if PYTHON_ENABLED
+ PYTHON_SD = python
+endif
+if JAVA_ENABLED
+ JAVA_SD = java
+endif
+
+SUBDIRS = lasso docs $(PYTHON_SD) $(JAVA_SD) tests
ABS_BUILDDIR = $(shell pwd)