summaryrefslogtreecommitdiffstats
path: root/src/include/configure.in
diff options
context:
space:
mode:
authorKen Raeburn <raeburn@mit.edu>2004-07-22 21:50:22 +0000
committerKen Raeburn <raeburn@mit.edu>2004-07-22 21:50:22 +0000
commit9e826ecf981c2fd5bc12df093964f721e711e223 (patch)
tree226bbae2dec919d7077da9c09870c26af7a748a2 /src/include/configure.in
parentc5c9301fa4b82e3b0a9910a77c239373e95e412b (diff)
downloadkrb5-9e826ecf981c2fd5bc12df093964f721e711e223.tar.gz
krb5-9e826ecf981c2fd5bc12df093964f721e711e223.tar.xz
krb5-9e826ecf981c2fd5bc12df093964f721e711e223.zip
* configure.in: Look for "struct lifconf" and maybe define HAVE_STRUCT_LIFCONF
git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@16620 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/include/configure.in')
-rw-r--r--src/include/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/include/configure.in b/src/include/configure.in
index 381836ccb..72de2b61b 100644
--- a/src/include/configure.in
+++ b/src/include/configure.in
@@ -207,6 +207,18 @@ if test $krb5_cv_has_type_socklen_t = yes; then
AC_DEFINE(HAVE_SOCKLEN_T,1,[Define if there is a socklen_t type. If not, probably use size_t])
fi
dnl
+AC_MSG_CHECKING(for struct lifconf)
+AC_CACHE_VAL(krb5_cv_has_struct_lifconf,
+[AC_TRY_COMPILE(
+[#include <sys/socket.h>
+#include <net/if.h>
+],[sizeof (struct lifconf);],
+krb5_cv_has_struct_lifconf=yes,krb5_cv_has_struct_lifconf=no)])
+AC_MSG_RESULT($krb5_cv_has_struct_lifconf)
+if test $krb5_cv_has_struct_lifconf = yes; then
+ AC_DEFINE(HAVE_STRUCT_LIFCONF,1,[Define if there is a struct lifconf.])
+fi
+dnl
dnl
KRB5_AC_NEED_BIND_8_COMPAT
dnl