summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorGreg Hudson <ghudson@mit.edu>2010-10-02 17:21:54 +0000
committerGreg Hudson <ghudson@mit.edu>2010-10-02 17:21:54 +0000
commit23f90e6bf3c7888ffbd59935ced87156d0be5a53 (patch)
treefefdfab6da9cc964de26d5915140aefe53103529 /src/configure.in
parent1827e342c54b79566e6270f764e14e01990633ab (diff)
downloadkrb5-23f90e6bf3c7888ffbd59935ced87156d0be5a53.tar.gz
krb5-23f90e6bf3c7888ffbd59935ced87156d0be5a53.tar.xz
krb5-23f90e6bf3c7888ffbd59935ced87156d0be5a53.zip
Merge branches/nss to trunk
git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@24416 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index 7d59a56d8..70e9817c3 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -123,8 +123,27 @@ AC_HELP_STRING([--with-crypto-impl=IMPL], [use specified crypto implementation @
[CRYPTO_IMPL=$withval
AC_MSG_RESULT("k5crypto will use \'$withval\'")
], withval=builtin)
+CRYPTO_IMPL_LIBS=
+CRYPTO_IMPL_CFLAGS=
+case "$withval" in
+builtin)
+ ;;
+openssl)
+ AC_CHECK_LIB(crypto, PKCS7_get_signer_info)
+ ;;
+nss)
+ CRYPTO_IMPL_CFLAGS=`pkg-config --cflags nss`
+ CRYPTO_IMPL_LIBS="-lnss3 $(pkg-config --libs nss-util)"
+ AC_DEFINE(CRYPTO_IMPL_NSS,1,[Define if crypto implementation is NSS])
+ ;;
+*)
+ AC_MSG_ERROR([Unknown crypto implementation $withval])
+ ;;
+esac
AC_CONFIG_COMMANDS(CRYPTO_IMPL, , CRYPTO_IMPL=$CRYPTO_IMPL)
AC_SUBST(CRYPTO_IMPL)
+AC_SUBST(CRYPTO_IMPL_CFLAGS)
+AC_SUBST(CRYPTO_IMPL_LIBS)
# --with-kdc-kdb-update makes the KDC update the database with last request
# information and failure information.