summaryrefslogtreecommitdiffstats
path: root/po/Makefile.am
diff options
context:
space:
mode:
authorDavid Woodhouse <David.Woodhouse@intel.com>2014-08-11 09:37:05 +0100
committerDavid Woodhouse <David.Woodhouse@intel.com>2014-08-11 17:51:50 +0100
commit2a38a0a1c10547522009a8aed515f618d50851fc (patch)
tree7288d164e8b8c8b8373b8dec6feea8a6f5725b77 /po/Makefile.am
parentdb07992146bd8cbde311178361ffa2335b92ef82 (diff)
downloadgss-ntlmssp-2a38a0a1c10547522009a8aed515f618d50851fc.tar.gz
gss-ntlmssp-2a38a0a1c10547522009a8aed515f618d50851fc.tar.xz
gss-ntlmssp-2a38a0a1c10547522009a8aed515f618d50851fc.zip
Add support for building with NLS
Diffstat (limited to 'po/Makefile.am')
-rw-r--r--po/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/po/Makefile.am b/po/Makefile.am
new file mode 100644
index 0000000..90b5b4a
--- /dev/null
+++ b/po/Makefile.am
@@ -0,0 +1,41 @@
+
+LINGUAS = @LINGUAS@
+MOFILES = $(LINGUAS:%=%.mo)
+POFILES = $(LINGUAS:%=%.po)
+
+noinst_DATA = $(MOFILES)
+
+SUFFIXES = .mo
+
+.po.mo:
+ rm -f && $(MSGFMT) -o $@ $<
+
+clean-local:
+ rm -f $(MOFILES)
+
+install-data-hook: all
+ linguas="$(LINGUAS)"; \
+ for l in $$linguas; do \
+ dir="$(DESTDIR)$(localedir)/$$l/LC_MESSAGES"; \
+ $(mkdir_p) $$dir; \
+ echo Installing $$l.mo to $$dir/$(PACKAGE).mo ; \
+ $(INSTALL_DATA) $$l.mo $$dir/$(PACKAGE).mo; \
+ done
+
+uninstall-hook:
+ linguas="$(LINGUAS)"; \
+ for l in $$linguas; do \
+ file="$(DESTDIR)$(localedir)/$$l/LC_MESSAGES/$(PACKAGE).mo"; \
+ if [ -r "$$file" ]; then \
+ echo "Removing $$file"; rm -f "$$file"; \
+ fi ; \
+ done
+
+# $(PACKAGE).pot is built by a rule in the parent directory Makefile
+# This rule isn't needed but is here for convenience if manually invoked
+.PHONY: $(PACKAGE).pot
+$(PACKAGE).pot:
+ $(MAKE) -C .. po/$@
+
+EXTRA_DIST = $(POFILES) LINGUAS
+DISTCLEANFILES=$(PACKAGE).pot