summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSimo Sorce <idra@samba.org>2013-07-04 16:37:12 -0400
committerSimo Sorce <simo@redhat.com>2013-07-18 22:37:25 -0400
commit994d9639caeec0164134e3bd6c16512defe93021 (patch)
treeb7709922d0159a6250bb59b23dcf8a14af752cce /configure.ac
parent399c16829ceb8dad8f3f6e25e626212e4fca332e (diff)
downloadgss-ntlmssp-994d9639caeec0164134e3bd6c16512defe93021.tar.gz
gss-ntlmssp-994d9639caeec0164134e3bd6c16512defe93021.tar.xz
gss-ntlmssp-994d9639caeec0164134e3bd6c16512defe93021.zip
NTLM Crypto functions
Adds crypto function helpers needed by NTLM authentication
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e3a6887..352d535 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,7 @@ m4_include([external/pkg.m4])
m4_include([external/docbook.m4])
m4_include([external/sizes.m4])
m4_include([external/ax_pthread.m4])
+m4_include([external/m4_ax_check_openssl.m4])
AX_PTHREAD(,[AC_MSG_ERROR([Could not find Pthreads support])])
@@ -86,6 +87,18 @@ AC_CHECK_LIB(gssapi_krb5, gss_export_cred,,
AC_SUBST([GSSAPI_CFLAGS])
AC_SUBST([GSSAPI_LIBS])
+AC_CHECK_HEADERS([unicase.h uniconv.h],,
+ [AC_MSG_ERROR([Could not find libunistring headers])])
+UNISTRING_LIBS="-lunistring"
+AC_CHECK_LIB(unistring, u8_toupper,,
+ [AC_MSG_ERROR([libunistring does not support u8_toupper])],
+ [$UNISTRING_LIBS])
+
+AX_CHECK_OPENSSL(,[AC_MSG_ERROR([Could not find OpenSSL support])])
+
+CRYPTO_LIBS="$OPENSSL_LIBS"
+AC_SUBST([CRYPTO_LIBS])
+
if test x$HAVE_MANPAGES != x; then
CHECK_XML_TOOLS
CHECK_STYLESHEET([$SGML_CATALOG_FILES],