summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Woodhouse <David.Woodhouse@intel.com>2014-08-11 09:37:05 +0100
committerDavid Woodhouse <David.Woodhouse@intel.com>2014-08-11 17:51:50 +0100
commit2a38a0a1c10547522009a8aed515f618d50851fc (patch)
tree7288d164e8b8c8b8373b8dec6feea8a6f5725b77 /configure.ac
parentdb07992146bd8cbde311178361ffa2335b92ef82 (diff)
downloadgss-ntlmssp-2a38a0a1c10547522009a8aed515f618d50851fc.tar.gz
gss-ntlmssp-2a38a0a1c10547522009a8aed515f618d50851fc.tar.xz
gss-ntlmssp-2a38a0a1c10547522009a8aed515f618d50851fc.zip
Add support for building with NLS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bdc562c..b548506 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,6 +108,20 @@ if test x$HAVE_WBCLIENT != x; then
AM_CHECK_WBCLIENT
fi
+if test x$HAVE_NLS != x; then
+ AC_CHECK_FUNC(dgettext, [],
+ AC_CHECK_LIB(intl, dgettext, [],
+ AC_ERROR([Could not find dgettext() function])))
+ AC_PATH_PROG(MSGFMT, msgfmt)
+ if test x$MSGFMT = x; then
+ AC_ERROR([Could not find msgfmt])
+ fi
+fi
+RAWLINGUAS=`sed -e "/^#/d" -e "s/#.*//" "${srcdir}/po/LINGUAS"`
+# Remove newlines
+LINGUAS=`echo $RAWLINGUAS`
+AC_SUBST(LINGUAS)
+
if test x$HAVE_MANPAGES != x; then
CHECK_XML_TOOLS
CHECK_STYLESHEET([$SGML_CATALOG_FILES],
@@ -125,6 +139,6 @@ abs_build_dir=`pwd`
AC_DEFINE_UNQUOTED([ABS_BUILD_DIR], ["$abs_build_dir"], [Absolute path to the build directory])
AC_SUBST([abs_builddir], $abs_build_dir)
-AC_CONFIG_FILES([Makefile man/Makefile
+AC_CONFIG_FILES([Makefile man/Makefile po/Makefile
contrib/gssntlmssp.spec examples/mech.ntlmssp])
AC_OUTPUT