summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Woodhouse <David.Woodhouse@intel.com>2014-08-11 09:37:05 +0100
committerDavid Woodhouse <David.Woodhouse@intel.com>2014-08-11 17:51:50 +0100
commit2a38a0a1c10547522009a8aed515f618d50851fc (patch)
tree7288d164e8b8c8b8373b8dec6feea8a6f5725b77 /Makefile.am
parentdb07992146bd8cbde311178361ffa2335b92ef82 (diff)
downloadgss-ntlmssp-2a38a0a1c10547522009a8aed515f618d50851fc.tar.gz
gss-ntlmssp-2a38a0a1c10547522009a8aed515f618d50851fc.tar.xz
gss-ntlmssp-2a38a0a1c10547522009a8aed515f618d50851fc.zip
Add support for building with NLS
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7327f34..e5dfdf1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,9 @@ SUBDIRS =
if HAVE_MANPAGES
SUBDIRS += man
endif
+if HAVE_NLS
+SUBDIRS += po
+endif
# Some old versions of automake don't define builddir
builddir ?= .
@@ -31,6 +34,9 @@ if HAVE_GCC
-Werror-implicit-function-declaration \
-fno-strict-aliasing
endif
+if HAVE_NLS
+ AM_CFLAGS += -DLOCALEDIR="\"$(localedir)\""
+endif
dist_pkgconfig_DATA =
@@ -100,6 +106,8 @@ gssapidir = $(includedir)/gssapi
dist_gssapi_HEADERS = \
src/gssapi_ntlmssp.h
+POTFILES = src/gss_err.c
+
####################
# Program Binaries #
####################
@@ -185,6 +193,14 @@ rpmroot:
mkdir -p $(RPMBUILD)/SPECS
mkdir -p $(RPMBUILD)/SRPMS
+po/$(PACKAGE).pot: $(POTFILES)
+ @echo "Regenerating $@" ; rm -f $@ && \
+ xgettext --directory=$(top_srcdir) --from-code=UTF-8 \
+ --sort-by-file --add-comments --keyword=_ --keyword=N_ \
+ --package-name="@PACKAGE@" --package-version="@VERSION@" \
+ --msgid-bugs-address="simo@samba.org" \
+ -o $@ $(POTFILES)
+
rpms: dist-gzip rpmroot
cp $(builddir)/contrib/gssntlmssp.spec $(RPMBUILD)/SPECS
cp $(distdir).tar.gz $(RPMBUILD)/SOURCES