summaryrefslogtreecommitdiffstats
path: root/pypi/ipaserver/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2017-02-17 17:46:42 +0100
committerMartin Basti <mbasti@redhat.com>2017-03-02 14:43:37 +0100
commitacdd1f59782bb836d6c4c255689918368adb8dab (patch)
treeef3613076589b322aa20e42abdf42664c0adaadd /pypi/ipaserver/setup.py
parente2b9ea2fd58b98edbb8d6aec97aadeea7cf11dcb (diff)
downloadfreeipa-acdd1f59782bb836d6c4c255689918368adb8dab.tar.gz
freeipa-acdd1f59782bb836d6c4c255689918368adb8dab.tar.xz
freeipa-acdd1f59782bb836d6c4c255689918368adb8dab.zip
Add placeholders for ipaplatform, ipaserver and ipatests
I also renamed the base directory to pypi and added a new build target pypi_packages. Signed-off-by: Christian Heimes <cheimes@redhat.com> Reviewed-By: Martin Basti <mbasti@redhat.com>
Diffstat (limited to 'pypi/ipaserver/setup.py')
-rwxr-xr-xpypi/ipaserver/setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/pypi/ipaserver/setup.py b/pypi/ipaserver/setup.py
new file mode 100755
index 000000000..73e1e6316
--- /dev/null
+++ b/pypi/ipaserver/setup.py
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2017 FreeIPA Contributors see COPYING for license
+#
+"""Dummy package for FreeIPA
+
+ipatests is not yet available as PyPI package.
+"""
+
+from os.path import abspath, dirname
+import sys
+
+if __name__ == '__main__':
+ # include ../../ for ipasetup.py
+ sys.path.append(dirname(dirname(dirname(abspath(__file__)))))
+ from ipasetup import ipasetup # noqa: E402
+
+ ipasetup(
+ name='ipaserver',
+ doc = __doc__,
+ packages=[
+ "ipaserver",
+ ],
+ install_requires=[
+ "ipaclient",
+ ]
+ )