summaryrefslogtreecommitdiffstats
path: root/ipaserver/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2017-02-25 11:06:04 +0100
committerMartin Basti <mbasti@redhat.com>2017-03-01 12:51:50 +0100
commit135d0b5dd111d40632e2cd5be8f5315684b45fc6 (patch)
treefebddf0f6f32904dc7d91487389dd7c0190e35d5 /ipaserver/setup.py
parentd00ae870dda2889545c9d93e82e44526bfd4f431 (diff)
downloadfreeipa-135d0b5dd111d40632e2cd5be8f5315684b45fc6.tar.gz
freeipa-135d0b5dd111d40632e2cd5be8f5315684b45fc6.tar.xz
freeipa-135d0b5dd111d40632e2cd5be8f5315684b45fc6.zip
Finish port to PyCA cryptography
* add missing default_backend * unpad encrypted data * use cryptography's hashes and HMAC construct * remove hard dependency on python-nss from setup.py Signed-off-by: Christian Heimes <cheimes@redhat.com> Reviewed-By: Stanislav Laznicka <slaznick@redhat.com>
Diffstat (limited to 'ipaserver/setup.py')
-rwxr-xr-xipaserver/setup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/ipaserver/setup.py b/ipaserver/setup.py
index 95ba5ebfc..d3c735c0f 100755
--- a/ipaserver/setup.py
+++ b/ipaserver/setup.py
@@ -58,7 +58,6 @@ if __name__ == '__main__':
"netaddr",
"pyasn1",
"pyldap",
- "python-nss",
"six",
# not available on PyPI
# "python-libipa_hbac",