summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-11-08 09:24:51 +0100
committerMartin Babinsky <mbabinsk@redhat.com>2016-11-09 13:08:32 +0100
commitf31a489d246e01250536b7187225fb7ca6398ba5 (patch)
tree90459feb40a97a94122cf294735c6066f781e5cc /configure.ac
parent14c1c8dfd0aa894af2d60dfa4f2ce2510d791328 (diff)
downloadfreeipa-f31a489d246e01250536b7187225fb7ca6398ba5.tar.gz
freeipa-f31a489d246e01250536b7187225fb7ca6398ba5.tar.xz
freeipa-f31a489d246e01250536b7187225fb7ca6398ba5.zip
Build: add JS lint target
https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Martin Basti <mbasti@redhat.com> Reviewed-By: Christian Heimes <cheimes@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7c7c31ed1..23c96c0cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -427,6 +427,21 @@ fi
AC_SUBST([PYLINT])
AM_CONDITIONAL([WITH_PYLINT], [test "x${PYLINT}" != "xno"])
+
+AC_ARG_WITH([jslint],
+ AS_HELP_STRING([--with-jslint=path to jsl],
+ [path to JavaScript lint]),
+dnl --without-jslint will set JSLINT=no
+ [JSLINT=$with_jslint],
+ [AC_PATH_PROG([JSLINT], [jsl])]
+)
+if test "x${JSLINT}" == "x"; then
+ AC_MSG_ERROR([cannot find JS lint])
+fi
+AC_SUBST([JSLINT])
+AM_CONDITIONAL([WITH_JSLINT], [test "x${JSLINT}" != "xno"])
+
+
# Flags
AC_SUBST(CFLAGS)