summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2016-12-02 23:42:58 +0100
committerMartin Babinsky <mbabinsk@redhat.com>2016-12-05 12:10:02 +0100
commitcac0c2d951e10d49372a038c73f796dc3beb62b9 (patch)
treedb513136bb56cc35753bd6acd8430adc4f5fdb46 /configure.ac
parent86295a8c2ea5c0546b070053d490b3a8b8013012 (diff)
downloadfreeipa-cac0c2d951e10d49372a038c73f796dc3beb62b9.tar.gz
freeipa-cac0c2d951e10d49372a038c73f796dc3beb62b9.tar.xz
freeipa-cac0c2d951e10d49372a038c73f796dc3beb62b9.zip
Relax check for .git to support freeipa in submodules
Let's relax the check for .git from directory to exists in order to support freeipa in a git submodule. Submodules have a .git file with content like gitdir: ../.git/modules/freeipa Signed-off-by: Christian Heimes <cheimes@redhat.com> Reviewed-By: Petr Spacek <pspacek@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 66e6e9bd0..6e31b29a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,7 +353,7 @@ dnl Are we in source tree?
AM_CONDITIONAL([IS_GIT_SNAPSHOT], [test "IPA_VERSION_IS_GIT_SNAPSHOT" == "yes"])
AM_COND_IF([IS_GIT_SNAPSHOT], [
AC_MSG_CHECKING([if source directory is a Git reposistory])
- if test ! -d "${srcdir}/.git"; then
+ if test ! -e "${srcdir}/.git"; then
AC_MSG_ERROR([Git reposistory is required by VERSION.m4 IPA_VERSION_IS_GIT_SNAPSHOT but not found])
else
AC_MSG_RESULT([yes])