summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-11-09 16:16:45 +0100
committerMartin Basti <mbasti@redhat.com>2016-11-11 10:41:38 +0100
commita691b7d1837595fecd37bf88a875cb0753f7e698 (patch)
tree948ffaa6e404de8add3dea4d9729a82fcc935b84 /configure.ac
parent3dc5d2c6f9a0fc134616c615634ae505ef753f77 (diff)
downloadfreeipa-a691b7d1837595fecd37bf88a875cb0753f7e698.tar.gz
freeipa-a691b7d1837595fecd37bf88a875cb0753f7e698.tar.xz
freeipa-a691b7d1837595fecd37bf88a875cb0753f7e698.zip
Build: IPA_VERSION_IS_GIT_SNAPSHOT re-generates version number on RPM build
This is a huge hack. rpms target will touch VERSION.m4 file. This change is then detected by automake Makefiles which subsequently re-execute configure and make. We have to workaround fact that variables in new make targets (executed after new configure) are different than original ones. Also, we have to 'bake-in' precise snapshot version from Git to VERSION.m4 inside of RPM tarball so the RPM does not depend on git anymore. All this magic slows build down a bit. Do not enable IPA_VERSION_IS_GIT_SNAPSHOT if you want fastest possible builds. The option IPA_VERSION_IS_GIT_SNAPSHOT is now enabled by default as it was before we started the build system refactoring effort. https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Tomas Krizek <tkrizek@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 53d5dab98..4d0b09c71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -372,6 +372,7 @@ AC_SUBST([DATA_VERSION], [IPA_DATA_VERSION])
AC_SUBST([NUM_VERSION], [IPA_NUM_VERSION])
AC_SUBST(VENDOR_SUFFIX)
AC_SUBST([VERSION], [IPA_VERSION])
+AC_SUBST([GIT_VERSION], [IPA_GIT_VERSION])
dnl ---------------------------------------------------------------------------
dnl Finish