summaryrefslogtreecommitdiffstats
path: root/asn1/asn1c/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2014-11-13 11:31:09 -0500
committerSimo Sorce <simo@redhat.com>2014-11-20 10:52:13 -0500
commitc6afc489a1c9d86fd593bd47c4a8dae6d9a008d2 (patch)
tree27ad9cc99e3c8e38b8df1adacb3cca5e3f8f1e43 /asn1/asn1c/Makefile.am
parentb170851058d6712442d553ef3d11ecd21b282443 (diff)
downloadfreeipa-c6afc489a1c9d86fd593bd47c4a8dae6d9a008d2.tar.gz
freeipa-c6afc489a1c9d86fd593bd47c4a8dae6d9a008d2.tar.xz
freeipa-c6afc489a1c9d86fd593bd47c4a8dae6d9a008d2.zip
Add asn1c generated code for keytab controls
Instead of manually encoding controls, use an actual asn1 compiler. The file asn1/asn1c/ipa.asn1 will contain ipa modules. The generated code is committed to the tree and built into a static library that is linked to the code that uses it. The first module implements the GetKeytabControl control. Related: https://fedorahosted.org/freeipa/ticket/4718 https://fedorahosted.org/freeipa/ticket/4728 Reviewed-By: Alexander Bokovoy <abokovoy@redhat.com> Reviewed-By: Nathaniel McCallum <npmccallum@redhat.com>
Diffstat (limited to 'asn1/asn1c/Makefile.am')
-rw-r--r--asn1/asn1c/Makefile.am93
1 files changed, 93 insertions, 0 deletions
diff --git a/asn1/asn1c/Makefile.am b/asn1/asn1c/Makefile.am
new file mode 100644
index 000000000..e4ed6ab79
--- /dev/null
+++ b/asn1/asn1c/Makefile.am
@@ -0,0 +1,93 @@
+NULL =
+
+ASN1C_SOURCES = \
+ INTEGER.c \
+ NativeEnumerated.c \
+ NativeInteger.c \
+ asn_SEQUENCE_OF.c \
+ asn_SET_OF.c \
+ constr_CHOICE.c \
+ constr_SEQUENCE.c \
+ constr_SEQUENCE_OF.c \
+ constr_SET_OF.c \
+ OCTET_STRING.c \
+ BIT_STRING.c \
+ asn_codecs_prim.c \
+ ber_tlv_length.c \
+ ber_tlv_tag.c \
+ ber_decoder.c \
+ der_encoder.c \
+ constr_TYPE.c \
+ constraints.c \
+ xer_support.c \
+ xer_decoder.c \
+ xer_encoder.c \
+ per_support.c \
+ per_decoder.c \
+ per_encoder.c \
+ $(NULL)
+
+ASN1C_HEADERS =
+ INTEGER.h \
+ NativeEnumerated.h \
+ NativeInteger.h \
+ asn_SEQUENCE_OF.h \
+ asn_SET_OF.h \
+ constr_CHOICE.h \
+ constr_SEQUENCE.h \
+ constr_SEQUENCE_OF.h \
+ constr_SET_OF.h \
+ asn_application.h \
+ asn_system.h \
+ asn_codecs.h \
+ asn_internal.h \
+ OCTET_STRING.h \
+ BIT_STRING.h \
+ asn_codecs_prim.h \
+ ber_tlv_length.h \
+ ber_tlv_tag.h \
+ ber_decoder.h \
+ der_encoder.h \
+ constr_TYPE.h \
+ constraints.h \
+ xer_support.h \
+ xer_decoder.h \
+ xer_encoder.h \
+ per_support.h \
+ per_decoder.h \
+ per_encoder.h \
+ $(NULL)
+
+ASN1Cdir = .
+
+IPAASN1_SOURCES= \
+ Int32.c \
+ GetKeytabControl.c \
+ GKNewKeys.c \
+ GKCurrentKeys.c \
+ GKReply.c \
+ KrbKey.c \
+ TypeValuePair.c \
+ $(NULL)
+
+IPAASN1_HEADERS= \
+ Int32.h \
+ GetKeytabControl.h \
+ GKNewKeys.h \
+ GKCurrentKeys.h \
+ GKReply.h \
+ KrbKey.h \
+ TypeValuePair.h \
+ $(NULL)
+
+IPAASN1dir = .
+
+AM_CPPFLAGS = -I../../util
+
+noinst_LTLIBRARIES=libasn1c.la
+noinst_HEADERS=$(ASN1C_HEADERS) $(IPAASN1_HEADERS)
+libasn1c_la_SOURCES=$(ASN1C_SOURCES) $(IPAASN1_SOURCES)
+
+regenerate:
+ asn1c -fskeletons-copy -fnative-types ipa.asn1
+ rm -f converter-sample.c Makefile.am.sample