summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2017-01-21 19:34:12 +0100
committerMartin Basti <mbasti@redhat.com>2017-02-15 17:30:36 +0100
commitff6e701b0077d9c8e2aacdcaecf70f885018db92 (patch)
tree9639b5636a9fcb3a93a7d408f6949a66ce82b97b /Makefile.am
parent1d7fcfe15d279e50d9ac29464a30f8e594db1802 (diff)
downloadfreeipa-ff6e701b0077d9c8e2aacdcaecf70f885018db92.tar.gz
freeipa-ff6e701b0077d9c8e2aacdcaecf70f885018db92.tar.xz
freeipa-ff6e701b0077d9c8e2aacdcaecf70f885018db92.zip
New lite-server implementation
The new development server depends on werkzeug instead of paste. The werkzeug WSGI server comes with some additional features, most noticeable multi-processing server. The IPA framework is not compatible with threaded servers. Werkzeug can serve static files easily and has a fast auto-reloader. The new lite-server implementation depends on PR 314 (privilege separation). For Python 3 support, it additionally depends on PR 393. Signed-off-by: Christian Heimes <cheimes@redhat.com> Reviewed-By: Martin Basti <mbasti@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9bfc899fe..30ad9bb55 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,6 @@ SUBDIRS = asn1 util client contrib daemons init install $(IPACLIENT_SUBDIRS) ipa
MOSTLYCLEANFILES = ipasetup.pyc ipasetup.pyo \
ignore_import_errors.pyc ignore_import_errors.pyo \
ipasetup.pyc ipasetup.pyo \
- lite-server.pyc lite-server.pyo \
pylint_plugins.pyc pylint_plugins.pyo
# user-facing scripts
@@ -14,7 +13,6 @@ dist_bin_SCRIPTS = ipa
# files required for build but not installed
dist_noinst_SCRIPTS = ignore_import_errors.py \
- lite-server.py \
makeapi \
makeaci \
make-doc \
@@ -119,6 +117,12 @@ _srpms-body: _rpms-prep
cp $(RPMBUILD)/SRPMS/*$$(cat $(top_builddir)/.version)*.src.rpm $(top_builddir)/dist/srpms/
rm -f rm -f $(top_builddir)/.version
+.PHONY: lite-server
+lite-server: $(top_builddir)/ipapython/version.py
+ +$(MAKE) -C $(top_builddir)/install/ui
+ PYTHONPATH=$(top_srcdir) $(PYTHON) -bb \
+ contrib/lite-server.py $(LITESERVER_ARGS)
+
.PHONY: lint
if WITH_POLINT
POLINT_TARGET = polint