summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-11-09 13:34:04 +0100
committerMartin Basti <mbasti@redhat.com>2016-11-10 12:37:58 +0100
commitd20f6a5ef2467e780026f1040f5a11a7a77594ca (patch)
treed9ebc027f4e8f381459201b2b085a8520fbc294b /Makefile.am
parentdc58f8f2a17adc642ae6f32fe9c9eb05d993c9d0 (diff)
downloadfreeipa-d20f6a5ef2467e780026f1040f5a11a7a77594ca.tar.gz
freeipa-d20f6a5ef2467e780026f1040f5a11a7a77594ca.tar.xz
freeipa-d20f6a5ef2467e780026f1040f5a11a7a77594ca.zip
Build: fix make clean to remove build artifacts from top-level directory
make lint and make dist were generating files which were not removed by make clean. https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Christian Heimes <cheimes@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ffa5de2d2..031aef4f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,11 @@
SUBDIRS = asn1 util client contrib daemons init install ipaclient ipalib ipaplatform ipapython ipaserver ipatests po
-MOSTLYCLEANFILES = ipasetup.pyc ipasetup.pyo
+MOSTLYCLEANFILES = ipasetup.pyc ipasetup.pyo \
+ ignore_import_errors.pyc ignore_import_errors.pyo \
+ ipasetup.pyc ipasetup.pyo \
+ lite-server.pyc lite-server.pyo \
+ pylint_plugins.pyc pylint_plugins.pyo \
+ $(TARBALL)
# user-facing scripts
dist_bin_SCRIPTS = ipa
@@ -25,6 +30,11 @@ EXTRA_DIST = .mailmap \
pylintrc \
pytest.ini
+clean-local:
+ rm -rf "$(RPMBUILD)"
+ rm -rf "$(top_builddir)/dist"
+ rm -rf "$(top_srcdir)/__pycache__"
+
# convenience targets for RPM build
RPMBUILD ?= $(abs_builddir)/rpmbuild
TARBALL = $(PACKAGE)-$(VERSION).tar.gz