summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2017-02-17 17:46:42 +0100
committerMartin Basti <mbasti@redhat.com>2017-03-02 14:43:37 +0100
commitacdd1f59782bb836d6c4c255689918368adb8dab (patch)
treeef3613076589b322aa20e42abdf42664c0adaadd /Makefile.am
parente2b9ea2fd58b98edbb8d6aec97aadeea7cf11dcb (diff)
downloadfreeipa-acdd1f59782bb836d6c4c255689918368adb8dab.tar.gz
freeipa-acdd1f59782bb836d6c4c255689918368adb8dab.tar.xz
freeipa-acdd1f59782bb836d6c4c255689918368adb8dab.zip
Add placeholders for ipaplatform, ipaserver and ipatests
I also renamed the base directory to pypi and added a new build target pypi_packages. Signed-off-by: Christian Heimes <cheimes@redhat.com> Reviewed-By: Martin Basti <mbasti@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9595c9dbe..26ba379c0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,6 +9,7 @@ if WITH_IPATESTS
endif
IPACLIENT_SUBDIRS = ipaclient ipalib ipapython
+IPA_PLACEHOLDERS = freeipa ipa ipaplatform ipaserver ipatests
SUBDIRS = asn1 util client contrib po pypi \
$(IPACLIENT_SUBDIRS) ipaplatform $(IPATESTS_SUBDIRS) $(SERVER_SUBDIRS)
@@ -204,7 +205,7 @@ jslint-html:
cd $(top_srcdir)/install/html; \
jsl -nologo -nosummary -nofilelisting -conf jsl.conf
-.PHONY: bdist_wheel wheel_bundle
+.PHONY: bdist_wheel wheel_bundle wheel_placeholder pypi_packages
WHEELDISTDIR = $(top_builddir)/dist/wheels
WHEELBUNDLEDIR = $(top_builddir)/dist/bundle
@@ -215,8 +216,6 @@ $(WHEELBUNDLEDIR):
mkdir -p $(WHEELBUNDLEDIR)
bdist_wheel: $(WHEELDISTDIR)
- $(MAKE) $(AM_MAKEFLAGS) -C packaging/ipa bdist_wheel || exit 1;
- $(MAKE) $(AM_MAKEFLAGS) -C packaging/freeipa bdist_wheel || exit 1;
for dir in $(IPACLIENT_SUBDIRS); do \
$(MAKE) $(AM_MAKEFLAGS) -C $${dir} $@ || exit 1; \
done
@@ -224,6 +223,15 @@ bdist_wheel: $(WHEELDISTDIR)
wheel_bundle: $(WHEELBUNDLEDIR) bdist_wheel
$(PYTHON) -m pip wheel --wheel-dir $(WHEELBUNDLEDIR) $(WHEELDISTDIR)/*.whl
+wheel_placeholder: $(WHEELDISTDIR)
+ for dir in $(IPA_PLACEHOLDERS); do \
+ $(MAKE) $(AM_MAKEFLAGS) -C $(top_srcdir)/pypi/$${dir} bdist_wheel || exit 1; \
+ done
+
+pypi_packages: bdist_wheel wheel_placeholder
+ @echo -e "\n\nTo upload packages to PyPI, run:\n"
+ @echo -e " twine upload $(WHEELDISTDIR)/*-$(VERSION)-py2.py3-none-any.whl\n"
+
.PHONY:
strip-po:
$(MAKE) -C po strip-po