summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-12-08 11:26:18 +0100
committerMartin Basti <mbasti@redhat.com>2016-12-13 14:36:11 +0100
commit9c87c39e65547004031284080749bc66dab1a8f9 (patch)
treeafa0ab1758b131fa88e4330d13861b87fe5de70c /Makefile.am
parent21a0987601dc4fa9de3fe63a18a604337a5edb7b (diff)
downloadfreeipa-9c87c39e65547004031284080749bc66dab1a8f9.tar.gz
freeipa-9c87c39e65547004031284080749bc66dab1a8f9.tar.xz
freeipa-9c87c39e65547004031284080749bc66dab1a8f9.zip
Build: always use Pylint from Python version used for rest of the build
configure option --with/without-pylint was replaced by --enable/disable-pylint. Pylint is always called as $(PYTHON) -m python. If you need to override Pylint version, use command "make pylint PYTHON=xxx". https://fedorahosted.org/freeipa/ticket/157 Reviewed-By: Martin Basti <mbasti@redhat.com> Reviewed-By: Christian Heimes <cheimes@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a7c74b06a..73bd37899 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -164,7 +164,7 @@ pylint: $(top_builddir)/ipapython/version.py ipasetup.py
-name '*.py' -print -o \
-type f -exec grep -qsm1 '^#!.*\bpython' '{}' \; -print`; \
echo "Pylint is running, please wait ..."; \
- PYTHONPATH=$(top_srcdir) $(PYLINT) \
+ PYTHONPATH=$(top_srcdir) $(PYTHON) -m pylint \
--rcfile=$(top_srcdir)/pylintrc $${FILES}
.PHONY: jslint jslint-ui jslint-ui-test jslint-html \