summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-11-15 16:43:58 +0100
committerMartin Basti <mbasti@redhat.com>2016-11-22 16:14:50 +0100
commit8a7962585069d7b0ff7e8d87ce094f07c16b3cd4 (patch)
tree418800cfd88cdc8df9e86228290b148772e64b74 /Makefile.am
parent9ef5a7de781f2508c2925225533973417458d0ea (diff)
downloadfreeipa-8a7962585069d7b0ff7e8d87ce094f07c16b3cd4.tar.gz
freeipa-8a7962585069d7b0ff7e8d87ce094f07c16b3cd4.tar.xz
freeipa-8a7962585069d7b0ff7e8d87ce094f07c16b3cd4.zip
Build: integrate translation system tests again
The Makefile test targets were lost when gettextize infrastructure was introduced. Now it is re-added in its modernized form which counts with generated .pot files. ipatests/i18n.py is now explicitly setting character encoding in files it generates. According to gettext manual chapter "Filling in the Header Entry" the Content-Type header is language-specific so it does not make sense to fill it in in .pot file. https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Martin Basti <mbasti@redhat.com> Reviewed-By: Christian Heimes <cheimes@redhat.com> Reviewed-By: Lukas Slebodnik <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 80f708b1d..07e998c60 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -128,7 +128,7 @@ apilint:
.PHONY: polint
polint:
- $(MAKE) -C $(srcdir)/po validate-src-strings
+ $(MAKE) -C $(srcdir)/po validate-src-strings validate-po test-gettext
# Run pylint for all python files. Finds all python files/packages, skips
# folders rpmbuild, freeipa-* and dist. Skip (match, but don't print) .*,