summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-11-22 16:07:32 +0100
committerMartin Basti <mbasti@redhat.com>2016-11-29 15:28:24 +0100
commit89739a6c910461a3cac3abc1bf2ff162c7c5bc82 (patch)
tree3f6c8a630bcebd2d6f33293cec6afa4237b193c4 /Makefile.am
parent6857de02f3a9c2d7e99e33863be3c65f71fa0d58 (diff)
downloadfreeipa-89739a6c910461a3cac3abc1bf2ff162c7c5bc82.tar.gz
freeipa-89739a6c910461a3cac3abc1bf2ff162c7c5bc82.tar.xz
freeipa-89739a6c910461a3cac3abc1bf2ff162c7c5bc82.zip
Build: properly integrate loader.js into build system
AC_CONFIG_FILES in configure.ac works well only with Makefiles. Other files have to be handled by Makefile.am so depedencies are tracked properly. https://fedorahosted.org/freeipa/ticket/6498 Reviewed-By: Martin Basti <mbasti@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c2826aea0..ad0ccd349 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -158,11 +158,15 @@ pylint:
PYTHONPATH=$(top_srcdir) $(PYLINT) \
--rcfile=$(top_srcdir)/pylintrc $${FILES}
-.PHONY: jslint jslint-ui jslint-ui-test jslint-html
+.PHONY: jslint jslint-ui jslint-ui-test jslint-html \
+ $(top_builddir)/install/ui/src/libs/loader.js
jslint: jslint-ui jslint-ui-test jslint-html
+$(top_builddir)/install/ui/src/libs/loader.js:
+ (cd $(top_builddir)/install/ui/src/libs && make loader.js)
+
# create temporary symlinks to allow jslint to find libs/loader.js
-jslint-ui:
+jslint-ui: $(top_builddir)/install/ui/src/libs/loader.js
cd $(top_srcdir)/install/ui; \
$(MKDIR_P) js; \
rm -f js/libs; \