summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2016-10-27 14:04:58 +0200
committerMartin Basti <mbasti@redhat.com>2016-11-16 22:58:39 +0100
commit8346e1b067483d4d836627a267805bbe8d6e7efa (patch)
treee4206cfe30c39cfcc7aebfa8937ea1620c623822 /Makefile.am
parent6ca96b3db03d4f3c5dbf465ca3d36bd563771c47 (diff)
downloadfreeipa-8346e1b067483d4d836627a267805bbe8d6e7efa.tar.gz
freeipa-8346e1b067483d4d836627a267805bbe8d6e7efa.tar.xz
freeipa-8346e1b067483d4d836627a267805bbe8d6e7efa.zip
Add install requirements to Python packages
https://fedorahosted.org/freeipa/ticket/6468 Signed-off-by: Christian Heimes <cheimes@redhat.com> Reviewed-By: Martin Basti <mbasti@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0ef543347..8c0c49492 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,5 @@
-SUBDIRS = asn1 util client contrib daemons init install ipaclient ipalib ipaplatform ipapython ipaserver ipatests po
+IPACLIENT_SUBDIRS = ipaclient ipalib ipaplatform ipapython
+SUBDIRS = asn1 util client contrib daemons init install $(IPACLIENT_SUBDIRS) ipaserver ipatests po
MOSTLYCLEANFILES = ipasetup.pyc ipasetup.pyo \
ignore_import_errors.pyc ignore_import_errors.pyo \
@@ -166,3 +167,21 @@ jslint-ui-test:
jslint-html:
cd $(top_srcdir)/install/html; \
jsl -nologo -nosummary -nofilelisting -conf jsl.conf
+
+.PHONY: bdist_wheel wheel_bundle
+WHEELDISTDIR = $(top_builddir)/dist/wheels
+WHEELBUNDLEDIR = $(top_builddir)/dist/bundle
+
+$(WHEELDISTDIR):
+ mkdir -p $(WHEELDISTDIR)
+
+$(WHEELBUNDLEDIR):
+ mkdir -p $(WHEELBUNDLEDIR)
+
+bdist_wheel: $(WHEELDISTDIR)
+ for dir in $(IPACLIENT_SUBDIRS); do \
+ $(MAKE) $(AM_MAKEFLAGS) -C $${dir} $@ || exit 1; \
+ done
+
+wheel_bundle: $(WHEELBUNDLEDIR) bdist_wheel
+ $(PYTHON) -m pip wheel --wheel-dir $(WHEELBUNDLEDIR) $(WHEELDISTDIR)/*.whl