summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2017-01-03 14:32:05 +0100
committerPetr Vobornik <pvoborni@redhat.com>2017-02-22 15:48:36 +0100
commit70554938d4f9ba5b347cd4bc8001428e905198e4 (patch)
tree5f61f9fe2d16f7661bc4347fc949809145f9267d /Makefile.am
parent908d2eaba46f5f123b49af400a8b696545c62b54 (diff)
downloadfreeipa-70554938d4f9ba5b347cd4bc8001428e905198e4.tar.gz
freeipa-70554938d4f9ba5b347cd4bc8001428e905198e4.tar.xz
freeipa-70554938d4f9ba5b347cd4bc8001428e905198e4.zip
Client-only builds with --disable-server
https://fedorahosted.org/freeipa/ticket/6517 Reviewed-By: Simo Sorce <ssorce@redhat.com> Reviewed-By: Tomas Krizek <tkrizek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 30ad9bb55..b12a77e53 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,14 @@
ACLOCAL_AMFLAGS = -I m4
+if ENABLE_SERVER
+ SERVER_SUBDIRS = daemons init install ipaserver
+else
+ SERVER_SUBDIRS =
+endif
IPACLIENT_SUBDIRS = ipaclient ipalib ipapython
-SUBDIRS = asn1 util client contrib daemons init install $(IPACLIENT_SUBDIRS) ipaplatform ipaserver ipatests po
+SUBDIRS = asn1 util client contrib po \
+ $(IPACLIENT_SUBDIRS) ipaplatform ipatests $(SERVER_SUBDIRS)
+
MOSTLYCLEANFILES = ipasetup.pyc ipasetup.pyo \
ignore_import_errors.pyc ignore_import_errors.pyo \