summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Cholasta <jcholast@redhat.com>2017-02-14 09:58:44 +0100
committerMartin Basti <mbasti@redhat.com>2017-03-10 13:04:59 +0100
commit5d489ac5604ca959cfe439c0594b8739073f3cea (patch)
treec91df525969f3148ce300acb2912756fee385960 /Makefile.am
parent6027a8111fa9ed7a058fb222f4f96b12039deb8b (diff)
downloadfreeipa-5d489ac5604ca959cfe439c0594b8739073f3cea.tar.gz
freeipa-5d489ac5604ca959cfe439c0594b8739073f3cea.tar.xz
freeipa-5d489ac5604ca959cfe439c0594b8739073f3cea.zip
pylint_plugins: add forbidden import checker
Add new pylint AST checker plugin which implements a check for imports forbidden in IPA. Which imports are forbidden is configurable in pylintrc. Provide default forbidden import configuration and disable the check for existing forbidden imports in our code base. Reviewed-By: Martin Basti <mbasti@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c8f32ac1..5d41e4af9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -180,7 +180,9 @@ pylint: $(top_builddir)/ipapython/version.py ipasetup.py
-type f -exec grep -qsm1 '^#!.*\bpython' '{}' \; -print`; \
echo "Pylint is running, please wait ..."; \
PYTHONPATH=$(top_srcdir) $(PYTHON) -m pylint \
- --rcfile=$(top_srcdir)/pylintrc $${FILES}
+ --rcfile=$(top_srcdir)/pylintrc \
+ --load-plugins pylint_plugins \
+ $${FILES}
.PHONY: jslint jslint-ui jslint-ui-test jslint-html \
$(top_builddir)/install/ui/src/libs/loader.js