summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-11-11 22:54:13 +0100
committerMartin Basti <mbasti@redhat.com>2016-11-22 16:14:50 +0100
commit4842231074683ff68be50b147560f5383aa305b6 (patch)
tree744404af4b8834f075c6137d5d9a20283d3da0b5 /Makefile.am
parent4225484356426a73cc11211bceda7f06ee23d093 (diff)
downloadfreeipa-4842231074683ff68be50b147560f5383aa305b6.tar.gz
freeipa-4842231074683ff68be50b147560f5383aa305b6.tar.xz
freeipa-4842231074683ff68be50b147560f5383aa305b6.zip
Build: use standard infrastructure for translations
We now use standard framework generatedby "gettextize" utility. It has two limitations which I do not consider sufficiently important to invest into hand-made solution: 1. It can automatically gather strings only from files which have some file extension like .c or .py. Right now we do not have any translatable strings in Python files without extensions. Given that these files will be removed from source tree and replaced with entry points from setuptools I do not see a reason to invest into supporting this. 2. It does not automatically strip untranslated strings from po files. This is a manual step in mainteiner's in workflow anyway so I will add separate Makefile target for it later on. This commit contains gettextize instrastructure + filled-in files Makevars and POTFILES.in. https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Martin Basti <mbasti@redhat.com> Reviewed-By: Christian Heimes <cheimes@redhat.com> Reviewed-By: Lukas Slebodnik <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8c0c49492..21b6782a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+ACLOCAL_AMFLAGS = -I m4
+
IPACLIENT_SUBDIRS = ipaclient ipalib ipaplatform ipapython
SUBDIRS = asn1 util client contrib daemons init install $(IPACLIENT_SUBDIRS) ipaserver ipatests po
@@ -23,6 +25,7 @@ EXTRA_DIST = .mailmap \
ACI.txt \
API.txt \
BUILD.txt \
+ config.rpath \
Contributors.txt \
COPYING.openssl \
contrib \