summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2017-02-21 21:55:21 +0100
committerPetr Vobornik <pvoborni@redhat.com>2017-02-22 15:48:36 +0100
commit2747f2ad782c7640ecc6949098f0d43411182255 (patch)
tree737d8b106ab4fa3f2498f25c1594a6a6422539d2 /Makefile.am
parent20c1eb9844223d892da47da1ea10662d37953ff8 (diff)
downloadfreeipa-2747f2ad782c7640ecc6949098f0d43411182255.tar.gz
freeipa-2747f2ad782c7640ecc6949098f0d43411182255.tar.xz
freeipa-2747f2ad782c7640ecc6949098f0d43411182255.zip
Add --without-ipatests option
--without-ipatests skips building and installation of the ipatests package. By default the ipatests package is always build and installed by make install. Signed-off-by: Christian Heimes <cheimes@redhat.com> Reviewed-By: Simo Sorce <ssorce@redhat.com> Reviewed-By: Tomas Krizek <tkrizek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b12a77e53..a35d18ffe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,12 +2,16 @@ ACLOCAL_AMFLAGS = -I m4
if ENABLE_SERVER
SERVER_SUBDIRS = daemons init install ipaserver
-else
- SERVER_SUBDIRS =
endif
+
+if WITH_IPATESTS
+ IPATESTS_SUBDIRS = ipatests
+endif
+
IPACLIENT_SUBDIRS = ipaclient ipalib ipapython
+
SUBDIRS = asn1 util client contrib po \
- $(IPACLIENT_SUBDIRS) ipaplatform ipatests $(SERVER_SUBDIRS)
+ $(IPACLIENT_SUBDIRS) ipaplatform $(IPATESTS_SUBDIRS) $(SERVER_SUBDIRS)
MOSTLYCLEANFILES = ipasetup.pyc ipasetup.pyo \