summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2017-01-03 18:04:53 +0100
committerMartin Basti <mbasti@redhat.com>2017-01-05 17:37:02 +0100
commit1e06a5195bafe0224d77371987f2509f5508ca2f (patch)
tree2549212ed9b99ab0480fa6be5ecd31b4a3101a2f /Makefile.am
parent3387734e6c6d47a756b5e914e7e515d2610a424f (diff)
downloadfreeipa-1e06a5195bafe0224d77371987f2509f5508ca2f.tar.gz
freeipa-1e06a5195bafe0224d77371987f2509f5508ca2f.tar.xz
freeipa-1e06a5195bafe0224d77371987f2509f5508ca2f.zip
Use pytest conftest.py and drop pytest.ini
Let's replace some ugly hacks with proper pytest conftest.py hooks. Test initialization of ipalib.api is now handled in pytest_cmdline_main(). Pytest plugins, markers and ignores are also moved into conftest.py. Additional guards make it possible to run tests without ipaserver installed. I added confcutdir to ensure that pytest does not leave our project space. Pytest used pytest.ini or setup.py before but pytest.ini is gone. Signed-off-by: Christian Heimes <cheimes@redhat.com> Reviewed-By: Milan Kubik <mkubik@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 73bd37899..9bfc899fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,8 +37,7 @@ EXTRA_DIST = .mailmap \
doc \
freeipa.spec.in \
ipasetup.py.in \
- pylintrc \
- pytest.ini
+ pylintrc
clean-local:
rm -rf "$(RPMBUILD)"