summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetr Spacek <pspacek@redhat.com>2016-11-01 12:56:40 +0100
committerMartin Babinsky <mbabinsk@redhat.com>2016-11-09 13:08:32 +0100
commit021a52d6801b74ded03cfdf6c7fb73bd1cab978f (patch)
tree9b866f9022d747932a4e81588281f619c16d1aa3 /Makefile.am
parent2f6712893be5e66260a169c367a4607be6043d11 (diff)
downloadfreeipa-021a52d6801b74ded03cfdf6c7fb73bd1cab978f.tar.gz
freeipa-021a52d6801b74ded03cfdf6c7fb73bd1cab978f.tar.xz
freeipa-021a52d6801b74ded03cfdf6c7fb73bd1cab978f.zip
Build: fix distribution and installation of static files in top-level directory
Static files from Git which are not touched by the build system have to be explicitly listed in Makefile.am so they get into tarball. ipa script was missing on installed systems for the same reason. https://fedorahosted.org/freeipa/ticket/6418 Reviewed-By: Martin Basti <mbasti@redhat.com> Reviewed-By: Christian Heimes <cheimes@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f36c3336..e76adf863 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,3 +5,24 @@ SUBDIRS = asn1 util client daemons install ipaclient ipalib ipaplatform ipapytho
# init
MOSTLYCLEANFILES = ipasetup.pyc ipasetup.pyo
+
+# user-facing scripts
+dist_bin_SCRIPTS = ipa
+
+# files required for build but not installed
+dist_noinst_SCRIPTS = ignore_import_errors.py \
+ lite-server.py \
+ makeapi \
+ makeaci \
+ make-doc \
+ make-test \
+ pylint_plugins.py
+
+EXTRA_DIST = .mailmap \
+ ACI.txt \
+ API.txt \
+ BUILD.txt \
+ Contributors.txt \
+ COPYING.openssl \
+ pylintrc \
+ pytest.ini