summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-11-18 15:29:58 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-11-26 16:51:41 +0100
commit03b859510dc13a13a456ca4aa94c0561a0e9684c (patch)
tree8c467eb8c7605ce9d3c65a9789363f64ff75d8cb /Makefile.am
parent5c129880ae10c80b4f79cb2994e9d127dc6dfbef (diff)
downloadsssd-03b859510dc13a13a456ca4aa94c0561a0e9684c.tar.gz
sssd-03b859510dc13a13a456ca4aa94c0561a0e9684c.tar.xz
sssd-03b859510dc13a13a456ca4aa94c0561a0e9684c.zip
AD: Add autofs provider
https://fedorahosted.org/sssd/ticket/1632 Adds the possibility to configure: autofs_provider = ad The AD autofs provider uses the rfc2307 (nis*) attribute maps. This is different (at the moment) from using autofs_provider=ldap with ldap_schema=ad. Reviewed-by: Ondrej Valousek <ondrejv2@fedoraproject.org> Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 848f70e48..d7a6f2952 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3028,6 +3028,11 @@ libsss_ad_la_SOURCES += \
src/providers/ad/ad_sudo.c
endif
+if BUILD_AUTOFS
+libsss_ad_la_SOURCES += \
+ src/providers/ad/ad_autofs.c
+endif
+
libsss_ad_la_CFLAGS = \
$(AM_CFLAGS) \
$(OPENLDAP_CFLAGS) \