summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2003-10-01 18:54:06 +0000
committerGerald Carter <jerry@samba.org>2003-10-01 18:54:06 +0000
commitdbf7fc4feb7f9c7cb720ce2dcbc8bb16badfe1f2 (patch)
tree1142743af09f526fb265c4a08155e9ff13cb4064 /source/configure.in
parent6b16d9e0ad9d79efb754cdccaf1d8f907eadaa9f (diff)
downloadsamba-dbf7fc4feb7f9c7cb720ce2dcbc8bb16badfe1f2.tar.gz
samba-dbf7fc4feb7f9c7cb720ce2dcbc8bb16badfe1f2.tar.xz
samba-dbf7fc4feb7f9c7cb720ce2dcbc8bb16badfe1f2.zip
save and restore CFLAGS before/after AC_PROG_CC; this macro seems to overwrite the CFLAGS variable
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 8f6c8452e35..7bbbb2ab317 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -166,6 +166,7 @@ AC_SUBST(EXTRA_ALL_TARGETS)
AC_ARG_ENABLE(debug,
[ --enable-debug Turn on compiler debugging information (default=no)],
[if eval "test x$enable_debug = xyes"; then
+ echo "DEBUGGING TURNED ON!!!!"
CFLAGS="${CFLAGS} -g"
fi])
@@ -192,7 +193,15 @@ then
fi
dnl Checks for programs.
+
+##
+## for some reason this macro resets the CFLAGS
+## so save and restore
+##
+OLD_CFLAGS=${CFLAGS}
AC_PROG_CC
+CFLAGS=${OLD_CFLAGS}
+
AC_PROG_INSTALL
AC_PROG_AWK
AC_PATH_PROG(PERL, perl)