summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJim McDonough <jmcd@samba.org>2002-05-16 20:28:52 +0000
committerJim McDonough <jmcd@samba.org>2002-05-16 20:28:52 +0000
commitd3222ecd1a024fd2e7ba72b1bc10a400d398a364 (patch)
tree15280cea0655e6158c592f595cbd21dfdb022a6f /source/configure.in
parent2605e483b309e62b4c5d39a2ac6d8b2257bb5a87 (diff)
downloadsamba-d3222ecd1a024fd2e7ba72b1bc10a400d398a364.tar.gz
samba-d3222ecd1a024fd2e7ba72b1bc10a400d398a364.tar.xz
samba-d3222ecd1a024fd2e7ba72b1bc10a400d398a364.zip
Fix for non-__va_copy systems. I had used AC_TRY_COMPILE, but even though
__va_copy wasn't defined, it compiled as though it were a function, but fails on a link. Oops.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index a5460b70dea..51722d6eb19 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1174,7 +1174,7 @@ if test x"$samba_cv_HAVE_GETTIMEOFDAY_TZ" = x"yes"; then
fi
AC_CACHE_CHECK([for __va_copy],samba_cv_HAVE_VA_COPY,[
-AC_TRY_COMPILE([#include <stdarg.h>
+AC_TRY_LINK([#include <stdarg.h>
va_list ap1,ap2;], [__va_copy(ap1,ap2);],
samba_cv_HAVE_VA_COPY=yes,samba_cv_HAVE_VA_COPY=no)])
if test x"$samba_cv_HAVE_VA_COPY" = x"yes"; then