summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2002-01-07 11:42:12 +0000
committerAndrew Tridgell <tridge@samba.org>2002-01-07 11:42:12 +0000
commitc98158f3f818118fb13cc7ae6f45634204343b46 (patch)
treebbb7f4d1f30e2047a6eb26f9cba86bed905f08b7 /source/configure.in
parent690cc12bad2a037684a43b0dcb48be8eb03aa7bc (diff)
downloadsamba-c98158f3f818118fb13cc7ae6f45634204343b46.tar.gz
samba-c98158f3f818118fb13cc7ae6f45634204343b46.tar.xz
samba-c98158f3f818118fb13cc7ae6f45634204343b46.zip
- use CFLAGS when linking shared libs (for things like -64 on irix)
- don't attempt to build winbindd if we can't do shared libs
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/source/configure.in b/source/configure.in
index 46b82af4b2d..2340a1129c0 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -782,7 +782,7 @@ AC_CACHE_CHECK([whether building shared libraries actually works],
ac_cv_shlib_works=no
# try building a trivial shared library
$CC $CPPFLAGS $CFLAGS $PICFLAG -c -o shlib.po ${srcdir-.}/tests/shlib.c &&
- $CC $LDSHFLAGS -o shlib.so shlib.po &&
+ $CC $CPPFLAGS $CFLAGS $LDSHFLAGS -o shlib.so shlib.po &&
ac_cv_shlib_works=yes
rm -f shlib.so shlib.po
])
@@ -2538,7 +2538,7 @@ fi
# Display test results
-if test x"$HAVE_WINBIND" = x"yes"; then
+if test x"$HAVE_WINBIND" = x"yes" && test x"$BLDSHARED" = x"true"; then
AC_MSG_RESULT(yes)