summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2003-01-16 02:39:58 +0000
committerJeremy Allison <jra@samba.org>2003-01-16 02:39:58 +0000
commita776fbef3244ae82a17c57a7f62de115fd023c86 (patch)
tree9bf9887a1d01be510ceafbeb31d7ccc8eee92e6b /source/configure.in
parent1af74785f334bd84b2d62e7fc2975f9477386acb (diff)
downloadsamba-a776fbef3244ae82a17c57a7f62de115fd023c86.tar.gz
samba-a776fbef3244ae82a17c57a7f62de115fd023c86.tar.xz
samba-a776fbef3244ae82a17c57a7f62de115fd023c86.zip
Fist part of fixes to make us compile with Heimdal. Don't explicitly
detect for now, I still have vague hopes of hiding the differences between MIT and Heimdal with a compatibility layer.... Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index 7e3ec6a256f..ad778bf88da 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -2032,12 +2032,15 @@ fi
# now check for gssapi headers. This is also done here to allow for
# different kerberos include paths
- AC_CHECK_HEADERS(gssapi/gssapi_generic.h gssapi/gssapi.h)
+ AC_CHECK_HEADERS(gssapi.h gssapi/gssapi_generic.h gssapi/gssapi.h)
##################################################################
# we might need the k5crypto and com_err libraries on some systems
AC_CHECK_LIB(com_err, _et_list, [LIBS="$LIBS -lcom_err"])
AC_CHECK_LIB(k5crypto, krb5_encrypt_data, [LIBS="$LIBS -lk5crypto"])
+ # Heimdal checks.
+ AC_CHECK_LIB(crypto, des_set_key, [LIBS="$LIBS -lcrypto"])
+ AC_CHECK_LIB(asn1, copy_Authenticator, [LIBS="$LIBS -lasn1 -lroken"])
########################################################
# now see if we can find the krb5 libs in standard paths
@@ -2049,6 +2052,9 @@ fi
# now see if we can find the gssapi libs in standard paths
AC_CHECK_LIB(gssapi_krb5, gss_display_status, [LIBS="$LIBS -lgssapi_krb5";
AC_DEFINE(HAVE_GSSAPI,1,[Whether GSSAPI is available])])
+ # Heimdal checks.
+ AC_CHECK_LIB(gssapi, gss_display_status, [LIBS="$LIBS -lgssapi";
+ AC_DEFINE(HAVE_GSSAPI,1,[Whether GSSAPI is available])])
fi
########################################################