summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2003-04-02 15:08:31 +0000
committerJelmer Vernooij <jelmer@samba.org>2003-04-02 15:08:31 +0000
commita5a980eb3efb37a6becacf043692361bdb4174b0 (patch)
tree5caf50a5e3f276755468825a7511fc91e2a0be7c /source/configure.in
parent1afb2695a020424d014c4dee9c6a73620281aaa8 (diff)
downloadsamba-a5a980eb3efb37a6becacf043692361bdb4174b0.tar.gz
samba-a5a980eb3efb37a6becacf043692361bdb4174b0.tar.xz
samba-a5a980eb3efb37a6becacf043692361bdb4174b0.zip
Only link in popt when we need it
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index d0c3e8e1fd7..266dffa38bb 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -3343,12 +3343,15 @@ AC_MSG_CHECKING(whether to use included popt)
if test x"$INCLUDED_POPT" = x"yes"; then
AC_MSG_RESULT(yes)
BUILD_POPT='$(POPT_OBJS)'
+ POPTLIBS='$(POPT_OBJS)'
FLAGS1="-I$srcdir/popt"
else
AC_MSG_RESULT(no)
- BUILD_POPT="-lpopt"
+ BUILD_POPT=""
+ POPTLIBS="-lpopt"
fi
AC_SUBST(BUILD_POPT)
+AC_SUBST(POPTLIBS)
AC_SUBST(FLAGS1)
#################################################