summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2005-09-17 13:08:49 +0000
committerJelmer Vernooij <jelmer@samba.org>2005-09-17 13:08:49 +0000
commita27a28da7ab1761d2591110381ceae731773910b (patch)
tree90c5b16781f5d0af433fa504b1c7f369bbbcf4a6 /source/configure.in
parent061a5825190db7afb8e471472b0445da4231c5da (diff)
downloadsamba-a27a28da7ab1761d2591110381ceae731773910b.tar.gz
samba-a27a28da7ab1761d2591110381ceae731773910b.tar.xz
samba-a27a28da7ab1761d2591110381ceae731773910b.zip
r10294: Generate Makefile directly rather then thru Makefile.in. Autoconf
substitution variables are now no longer used. This is one more step towards a (hopefully) perl-based configure
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/source/configure.in b/source/configure.in
index 752b7ad52f9..6da3a52c331 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -84,6 +84,8 @@ dnl Remove -I/usr/include/? from CFLAGS and CPPFLAGS
CFLAGS_REMOVE_USR_INCLUDE(CFLAGS)
CFLAGS_REMOVE_USR_INCLUDE(CPPFLAGS)
+AC_SUBST(ac_default_prefix)
+
echo "configure: creating config.pm"
cat >config.pm<<CEOF
# config.pm - Autogenerate by configure. DO NOT EDIT!
@@ -112,4 +114,5 @@ $SMB_INFO_SUBSYSTEMS
$SMB_INFO_LIBRARIES
CEOF
-AC_OUTPUT(Makefile,,[$PERL -Ibuild build/smb_build/main.pl])
+AC_OUTPUT_COMMANDS([$PERL -Ibuild build/smb_build/main.pl],[PERL="$PERL"])
+AC_OUTPUT