summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2000-06-29 08:23:56 +0000
committerAndrew Tridgell <tridge@samba.org>2000-06-29 08:23:56 +0000
commit7752c14c313bf9b565828181647fb71457167d92 (patch)
treeefb0e9feb56e0c70e82f1b6e02a96b65ef24eca8 /source/configure.in
parentfae3acc574c6e78121e6a1d464b67a15fb025304 (diff)
downloadsamba-7752c14c313bf9b565828181647fb71457167d92.tar.gz
samba-7752c14c313bf9b565828181647fb71457167d92.tar.xz
samba-7752c14c313bf9b565828181647fb71457167d92.zip
simpler configure test
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in3
1 files changed, 1 insertions, 2 deletions
diff --git a/source/configure.in b/source/configure.in
index b8a7226e920..db7ac60c9b8 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -729,8 +729,7 @@ AC_TRY_RUN([
#define F_NOTIFY 1026
#endif
main() {
- signal(SIGIO, SIG_IGN);
- exit(fcntl(open("/tmp", O_RDONLY), F_NOTIFY, 0xF) != 0);
+ exit(fcntl(open("/tmp", O_RDONLY), F_NOTIFY, 0) == -1 ? 1 : 0);
}
],
samba_cv_HAVE_KERNEL_CHANGE_NOTIFY=yes,samba_cv_HAVE_KERNEL_CHANGE_NOTIFY=no,samba_cv_HAVE_KERNEL_CHANGE_NOTIFY=cross)])