summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2001-10-16 11:40:09 +0000
committerAndrew Tridgell <tridge@samba.org>2001-10-16 11:40:09 +0000
commit2667dea146169658f3c0290bb78dc5854c821eb4 (patch)
treece005ef2827a53fe028c067d7a9043f7ec3b8111 /source/configure.in
parentf1f1a14598be64d4930049691ca970fe93506007 (diff)
downloadsamba-2667dea146169658f3c0290bb78dc5854c821eb4.tar.gz
samba-2667dea146169658f3c0290bb78dc5854c821eb4.tar.xz
samba-2667dea146169658f3c0290bb78dc5854c821eb4.zip
fix linking of k5crypto library on openbsd
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/source/configure.in b/source/configure.in
index dab7ab4ab32..f888db47ac4 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -1611,7 +1611,7 @@ AC_ARG_WITH(krb5,
*)
AC_MSG_RESULT(yes)
AC_DEFINE(KRB5_AUTH)
- LIBS="$LIBS -lkrb5 -lk5crypto -lcom_err"
+ LIBS="$LIBS -lkrb5"
CFLAGS="$CFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
AC_DEFINE(HAVE_KRB5)
@@ -1626,10 +1626,14 @@ AC_ARG_WITH(krb5,
########################################################
# now see if we can find the krb5 libs in standard paths
if test x$have_krb5 != xyes; then
-AC_CHECK_LIB(krb5, krb5_mk_req_extended, [LIBS="$LIBS -lkrb5 -lk5crypto -lcom_err";
+AC_CHECK_LIB(krb5, krb5_mk_req_extended, [LIBS="$LIBS -lkrb5";
AC_DEFINE(HAVE_KRB5)])
fi
+##################################################################
+# we might need the k5crypto and com_err libraries on some systems
+AC_CHECK_LIB(k5crypto, krb5_encrypt_data)
+AC_CHECK_LIB(com_err, _et_list)
#################################################
# check for automount support