summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2003-04-10 05:16:49 +0000
committerTim Potter <tpot@samba.org>2003-04-10 05:16:49 +0000
commit1cc5b2881c61db7aadd886008fcfb81e351e651a (patch)
tree3a8b25f4a920e32a04b0258c8062b57c8251ccac /source/configure.in
parentbc094789b972ac5ccc7ea3944c7ddb98581cf613 (diff)
downloadsamba-1cc5b2881c61db7aadd886008fcfb81e351e651a.tar.gz
samba-1cc5b2881c61db7aadd886008fcfb81e351e651a.tar.xz
samba-1cc5b2881c61db7aadd886008fcfb81e351e651a.zip
Fixes to linker flags for AIX winbind client from Stephen Roylance.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 2b086d3d3b1..c2b7ae27654 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -3222,7 +3222,11 @@ AC_MSG_CHECKING(whether to build winbind)
HAVE_WINBIND=yes
+# Define the winbind shared library name and any specific linker flags
+# it needs to be built with.
+
WINBIND_NSS=libnss_winbind
+WINBIND_NSS_LDSHFLAGS=$LDSHFLAGS
case "$host_os" in
*linux*)
@@ -3244,6 +3248,7 @@ case "$host_os" in
;;
*aix*)
WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_aix.o"
+ WINBIND_NSS_LDSHFLAGS="-Wl,-bexpall,-bM:SRE,-ewb_aix_init"
;;
*)
HAVE_WINBIND=no
@@ -3252,6 +3257,7 @@ case "$host_os" in
esac
AC_SUBST(WINBIND_NSS)
+AC_SUBST(WINBIND_NSS_LDSHFLAGS)
AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
AC_SUBST(WINBIND_NSS_EXTRA_LIBS)