summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2002-03-01 01:03:06 +0000
committerJeremy Allison <jra@samba.org>2002-03-01 01:03:06 +0000
commit10e3e6855be93b8c4d97d67a063d92ccee391fec (patch)
treebd24d169c4e641111e0df3713cf4a9b083858718 /source/configure.in
parent2a30960276ae65b60d01caf9464808d75a812e40 (diff)
downloadsamba-10e3e6855be93b8c4d97d67a063d92ccee391fec.tar.gz
samba-10e3e6855be93b8c4d97d67a063d92ccee391fec.tar.xz
samba-10e3e6855be93b8c4d97d67a063d92ccee391fec.zip
Attempt to fix Solaris winbind nss build.
Jeremy.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in23
1 files changed, 17 insertions, 6 deletions
diff --git a/source/configure.in b/source/configure.in
index e700305283c..9288f1cff58 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -2572,14 +2572,23 @@ AC_MSG_CHECKING(whether to build winbind)
# Initially, the value of $host_os decides whether winbind is supported
-case "$host_os" in
- *linux*|*solaris*|*irix*)
+case "$host_os" in
+ *linux*|*irix*)
HAVE_WINBIND=yes
- ;;
- *)
+ ;;
+ *solaris*)
+ HAVE_WINBIND=yes
+ WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_solaris"
+ WINBIND_NSS_EXTGRA_LIBS="-lsocket"
+ ;;
+ *hpux11*)
+ HAVE_WINBIND=yes
+ WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_solaris"
+ ;;
+ *)
HAVE_WINBIND=no
- winbind_no_reason=", unsupported on $host_os"
- ;;
+ winbind_no_reason=", unsupported on $host_os"
+ ;;
esac
# Check the setting of --with-winbindd
@@ -2635,6 +2644,8 @@ AC_SUBST(WINBIND_TARGETS)
AC_SUBST(WINBIND_STARGETS)
AC_SUBST(WINBIND_LTARGETS)
AC_SUBST(WINBIND_PAM_TARGETS)
+AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
+AC_SUBST(WINBIND_NSS_EXTRA_LIBS)
#################################################
# Check to see if we should use the included popt