summaryrefslogtreecommitdiffstats
path: root/source/configure.in
diff options
context:
space:
mode:
authorSimo Sorce <idra@samba.org>2003-04-02 10:36:02 +0000
committerSimo Sorce <idra@samba.org>2003-04-02 10:36:02 +0000
commit02781320476ed1b7ee5d943fa36f9a66ab67f208 (patch)
tree3e204e20b6e77959124f3679a89094db99655d5d /source/configure.in
parentd84a3fc522a588bdcd36cb86df304572947a456a (diff)
downloadsamba-02781320476ed1b7ee5d943fa36f9a66ab67f208.tar.gz
samba-02781320476ed1b7ee5d943fa36f9a66ab67f208.tar.xz
samba-02781320476ed1b7ee5d943fa36f9a66ab67f208.zip
THE Idmap patch :-)
includes a --with-idmap=no switch to disable idmap usage if you find problems. cosmetic fixes and param aliases to separate winbind from idamp roles. A temporarily remote idmap winbind compatibility backend. As I have time I will further change code to not call directly winbind (partly done but not tested) and a specilized module will be built in place for the current glue hack. The patch has been tested locally in my limited time, the patch is simple and clear and should not reserve problems, if any just disable it. As usual, comments and fisex are welcome :-) Simo.
Diffstat (limited to 'source/configure.in')
-rw-r--r--source/configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/source/configure.in b/source/configure.in
index 38716aee18c..3a6641d44a6 100644
--- a/source/configure.in
+++ b/source/configure.in
@@ -2442,6 +2442,27 @@ AC_ARG_WITH(ldapsam,
AC_MSG_RESULT(no)
)
+#################################################
+# check for IDMAP
+
+AC_DEFINE(WITH_IDMAP,1, [Include IDMAP support])
+
+AC_MSG_CHECKING(whether to use IDMAP only for [ug]id mapping)
+AC_ARG_WITH(idmap,
+[ --with-idmap Include experimental IDMAP support (default=yes)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_IDMAP,1,[Whether to include experimental IDMAP support])
+ ;;
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(WITH_IDMAP,0,[Whether to include experimental IDMAP support])
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
########################################################################################
##
## END OF TESTS FOR SAM BACKENDS.