summaryrefslogtreecommitdiffstats
path: root/packaging/Debian/debian/patches/installswat.sh.patch
diff options
context:
space:
mode:
authorEloy Paris <peloy@samba.org>2003-09-08 14:48:09 +0000
committerEloy Paris <peloy@samba.org>2003-09-08 14:48:09 +0000
commit7d8d193c05d60ab9b86d52075bb9ec5ad1857903 (patch)
tree0f165e0dc5c5043858d86da2e09f54ba8451c077 /packaging/Debian/debian/patches/installswat.sh.patch
parent15d53fd53c622de316d0ff41f1b60f0e2c69f908 (diff)
downloadsamba-7d8d193c05d60ab9b86d52075bb9ec5ad1857903.tar.gz
samba-7d8d193c05d60ab9b86d52075bb9ec5ad1857903.tar.xz
samba-7d8d193c05d60ab9b86d52075bb9ec5ad1857903.zip
Sync'ing packaging/Debian/ with the latest files from the official
Debian packages. This files are in sync. with the Debian packages for 3.0.0rc2.
Diffstat (limited to 'packaging/Debian/debian/patches/installswat.sh.patch')
-rw-r--r--packaging/Debian/debian/patches/installswat.sh.patch26
1 files changed, 9 insertions, 17 deletions
diff --git a/packaging/Debian/debian/patches/installswat.sh.patch b/packaging/Debian/debian/patches/installswat.sh.patch
index ff5f23a1cf3..b425e3bef76 100644
--- a/packaging/Debian/debian/patches/installswat.sh.patch
+++ b/packaging/Debian/debian/patches/installswat.sh.patch
@@ -1,5 +1,5 @@
---- samba-3.0alpha23.orig/source/script/installswat.sh 2001-10-17 16:00:14.000000000 -0400
-+++ samba-3.0alpha23/source/script/installswat.sh 2003-04-06 03:18:29.000000000 -0400
+--- samba_3_0/source/script/installswat.sh.orig 2003-08-28 18:03:10.000000000 -0400
++++ samba_3_0/source/script/installswat.sh 2003-08-28 18:11:14.000000000 -0400
@@ -9,7 +9,7 @@
echo Installing the Samba Web Administration Tool
@@ -36,7 +36,7 @@
FNAME=$SWATDIR/$ln/help/`basename $f`
echo $FNAME
if [ "x$BOOKDIR" = "x" ]; then
-@@ -49,31 +45,31 @@
+@@ -49,26 +45,24 @@
cp $f $FNAME || echo Cannot install $FNAME. Does $USER have privileges?
rm -f $f
chmod 0644 $FNAME
@@ -62,23 +62,15 @@
cp $f $FNAME || echo Cannot install $FNAME. Does $USER have privileges?
chmod 0644 $FNAME
+ done
++
done
+# Install html documentation
+for f in $SRCDIR../docs/htmldocs/*.html; do
-+ FNAME=$SWATDIR/help/`basename $f`
-+ echo $FNAME
-+ ln -s ../../../doc/samba-doc/htmldocs/`basename $f` $FNAME || echo Cannot install $FNAME. Does $USER have privileges?
-+# chmod 0644 $FNAME
++ FNAME=$SWATDIR/help/`basename $f`
++ echo $FNAME
++ ln -s ../../../doc/samba-doc/htmldocs/`basename $f` $FNAME || echo Cannot install $FNAME. Does $USER have privileges?
++ chmod 0644 $FNAME
done
- # Install Using Samba book
-
--if [ "x$BOOKDIR" != "x" ]; then
-+# For Debian we do not install anything here, we just create a symlink
-+# pointing to /usr/share/doc/samba-doc/htmldocs/using_samba/ in
-+# debian/rules (peloy@debian.org)
-+if /bin/false; then
-
- # Create directories
-
+ # Install Using Samba book (but only if it is there)