summaryrefslogtreecommitdiffstats
path: root/ctdb/configure.ac
diff options
context:
space:
mode:
authorMathieu PARENT <math.parent@gmail.com>2009-02-04 00:15:57 +0100
committerMichael Adam <obnox@samba.org>2009-02-04 00:19:22 +0100
commitf0d585217e452052da59b68e6e59bfa2df5d3963 (patch)
tree2c52579582b149d866a6b048a3deece5da956b5a /ctdb/configure.ac
parent62f27d0cb38184d82b2377b86f5e93135f614484 (diff)
downloadsamba-f0d585217e452052da59b68e6e59bfa2df5d3963.tar.gz
samba-f0d585217e452052da59b68e6e59bfa2df5d3963.tar.xz
samba-f0d585217e452052da59b68e6e59bfa2df5d3963.zip
build: Make log-directory configurable indepently of VARDIR
This adds a new configure option "--with-logdir". logdir defaults to "${localstatedir}/log" . It is important to have logdir configurable for debian systems, where localstatedir is set to "/var/lib" and not "/var". Signed-off-by: Michael Adam <obnox@samba.org> (This used to be ctdb commit b0c6854d1e886456fabdc8f1c3bd21c89311c601)
Diffstat (limited to 'ctdb/configure.ac')
-rw-r--r--ctdb/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/ctdb/configure.ac b/ctdb/configure.ac
index d552eed00b4..88c82f0308e 100644
--- a/ctdb/configure.ac
+++ b/ctdb/configure.ac
@@ -37,6 +37,17 @@ if test "$ac_cv_prog_gcc" = yes; then
CFLAGS="$CFLAGS -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings"
fi
+LOGDIR='${localstatedir}/log'
+AC_ARG_WITH([logdir],
+ [ --with-logdir=DIR path to log directory],
+ LOGDIR=$withval)
+if test ! -z "$LOGDIR"; then
+ if test "$LOGDIR" = "yes" -o "$LOGDIR" = "no"; then
+ AC_MSG_ERROR([--with-logdir must specify a path])
+ fi
+fi
+AC_SUBST(LOGDIR)
+
AC_CONFIG_HEADER(config.h)
EXTRA_OBJ=""