summaryrefslogtreecommitdiffstats
path: root/ctdb/configure.ac
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2007-10-15 14:44:06 +1000
committerAndrew Tridgell <tridge@samba.org>2007-10-15 14:44:06 +1000
commitd7f6b63f0a026494152f15822271521d8eec7393 (patch)
tree10f7f3b130489435250e2c5ac874835add98de7a /ctdb/configure.ac
parent574db736f27e84637a58a868ec7db25912ad5733 (diff)
downloadsamba-d7f6b63f0a026494152f15822271521d8eec7393.tar.gz
samba-d7f6b63f0a026494152f15822271521d8eec7393.tar.xz
samba-d7f6b63f0a026494152f15822271521d8eec7393.zip
only link to -lipq if needed
(This used to be ctdb commit 7c378d881e37db0f14e07ccba19fde1f9f4f0831)
Diffstat (limited to 'ctdb/configure.ac')
-rw-r--r--ctdb/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/ctdb/configure.ac b/ctdb/configure.ac
index b782c70f056..d552eed00b4 100644
--- a/ctdb/configure.ac
+++ b/ctdb/configure.ac
@@ -49,6 +49,12 @@ m4_include(ib/config.m4)
AC_CHECK_HEADERS(libipq.h linux/netfilter.h)
+IPQ_LIBS=""
+if test x"$ac_cv_header_libipq_h" = x"yes"; then
+ IPQ_LIBS="-lipq"
+fi
+AC_SUBST(IPQ_LIBS)
+
AC_CHECK_HEADERS(sched.h)
AC_CHECK_FUNCS(sched_setscheduler)