summaryrefslogtreecommitdiffstats
path: root/ctdb/configure.ac
diff options
context:
space:
mode:
authorDavid Disseldorp <ddiss@samba.org>2012-10-18 16:55:19 +0200
committerAmitay Isaacs <amitay@gmail.com>2012-10-21 01:39:08 +1100
commit8cbf1a00c41e5029ef4a9e0ab1fcc93f9e9e2b38 (patch)
tree8947502ffe190e5e754dbab1564d0be7ece012b8 /ctdb/configure.ac
parentd39fbd60b908013f8723c0167224288547833e95 (diff)
downloadsamba-8cbf1a00c41e5029ef4a9e0ab1fcc93f9e9e2b38.tar.gz
samba-8cbf1a00c41e5029ef4a9e0ab1fcc93f9e9e2b38.tar.xz
samba-8cbf1a00c41e5029ef4a9e0ab1fcc93f9e9e2b38.zip
Build: Set the default ctdb socket path at configure time
The ctdb socket path currently defaults to /tmp/ctdb.socket and can be modified at runtime using the --socket=filename option, common to both ctdb and ctdbd binaries. This change allows the default path to be set at configure time using the --with-socketpath=FILE argument. When not specified, the default path remains /tmp/ctdb.socket, documentation remains unchanged as a result. Signed-off-by: David Disseldorp <ddiss@samba.org> (This used to be ctdb commit f92b9c83a2f39fba9a141417a88de96fc8c592ff)
Diffstat (limited to 'ctdb/configure.ac')
-rw-r--r--ctdb/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/ctdb/configure.ac b/ctdb/configure.ac
index 50d20a04a16..85934a72b0d 100644
--- a/ctdb/configure.ac
+++ b/ctdb/configure.ac
@@ -71,6 +71,17 @@ if test ! -z "$LOGDIR"; then
fi
AC_SUBST(LOGDIR)
+SOCKPATH='/tmp/ctdb.socket'
+AC_ARG_WITH([socketpath],
+ [ --with-socketpath=FILE path to CTDB daemon socket [[/tmp/ctdb.socket]]],
+ SOCKPATH=$withval)
+if test ! -z "$SOCKPATH"; then
+ if test "$SOCKPATH" = "yes" -o "$SOCKPATH" = "no"; then
+ AC_MSG_ERROR([--with-socketpath must specify a file path])
+ fi
+fi
+AC_SUBST(SOCKPATH)
+
AC_CONFIG_HEADER(config.h)
EXTRA_OBJ=""