summaryrefslogtreecommitdiffstats
path: root/daemons/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'daemons/configure.ac')
-rw-r--r--daemons/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/daemons/configure.ac b/daemons/configure.ac
index 15ea00b0a..835d0b368 100644
--- a/daemons/configure.ac
+++ b/daemons/configure.ac
@@ -179,6 +179,16 @@ AC_CHECK_LIB([pdb],[pdb_enum_upn_suffixes],
[$SAMBA40EXTRA_LIBPATH])
dnl ---------------------------------------------------------------------------
+dnl Check for libunistring
+dnl ---------------------------------------------------------------------------
+AC_CHECK_HEADERS([unicase.h],,AC_MSG_ERROR([Could not find unicase.h]))
+AC_CHECK_LIB([unistring],
+ [ulc_casecmp],
+ [UNISTRING_LIBS="-lunistring"],
+ [AC_MSG_ERROR([libunistring does not have ulc_casecmp])])
+AC_SUBST(UNISTRING_LIBS)
+
+dnl ---------------------------------------------------------------------------
dnl Check for libverto
dnl ---------------------------------------------------------------------------
PKG_CHECK_MODULES([LIBVERTO], [libverto])