summaryrefslogtreecommitdiffstats
path: root/daemons/ipa-sam/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2015-12-01 13:43:35 -0500
committerMartin Basti <mbasti@redhat.com>2016-02-01 13:28:39 +0100
commitf9ed0b6ff8bf7e59de5450200d9fc5ad6e05299c (patch)
treece1f694f602f37a202f90fc07423d613cd0daa0b /daemons/ipa-sam/Makefile.am
parente011b376a5d071492bf3adfae26e4d61e2face07 (diff)
downloadfreeipa-f9ed0b6ff8bf7e59de5450200d9fc5ad6e05299c.tar.gz
freeipa-f9ed0b6ff8bf7e59de5450200d9fc5ad6e05299c.tar.xz
freeipa-f9ed0b6ff8bf7e59de5450200d9fc5ad6e05299c.zip
Convert ipa-sam to use the new getkeytab control
Signed-off-by: Simo Sorce <simo@redhat.com> Ticket: https://fedorahosted.org/freeipa/ticket/5495 Reviewed-By: Alexander Bokovoy <abokovoy@redhat.com>
Diffstat (limited to 'daemons/ipa-sam/Makefile.am')
-rw-r--r--daemons/ipa-sam/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/daemons/ipa-sam/Makefile.am b/daemons/ipa-sam/Makefile.am
index 46c813af5..ea14661b6 100644
--- a/daemons/ipa-sam/Makefile.am
+++ b/daemons/ipa-sam/Makefile.am
@@ -8,10 +8,12 @@ SAMBA40EXTRA_LIBS = $(SAMBA40EXTRA_LIBPATH) \
KRB5_UTIL_DIR=../../util
KRB5_UTIL_SRCS=$(KRB5_UTIL_DIR)/ipa_krb5.c $(KRB5_UTIL_DIR)/ipa_pwd_ntlm.c
+ASN1_UTIL_DIR=../../asn1
AM_CPPFLAGS = \
-I. \
-I$(srcdir) \
+ -I$(ASN1_UTIL_DIR) \
-I/usr/include/samba-4.0 \
-DPREFIX=\""$(prefix)"\" \
-DBINDIR=\""$(bindir)"\" \
@@ -54,6 +56,7 @@ ipasam_la_LIBADD = \
$(NDR_LIBS) \
$(SAMBA40EXTRA_LIBS) \
$(SSSIDMAP_LIBS) \
+ $(ASN1_UTIL_DIR)/libipaasn1.la \
$(NULL)
EXTRA_DIST = \