summaryrefslogtreecommitdiffstats
path: root/daemons/ipa-sam/Makefile.am
diff options
context:
space:
mode:
authorAlexander Bokovoy <abokovoy@redhat.com>2015-01-12 13:36:36 +0200
committerMartin Kosek <mkosek@redhat.com>2015-01-19 10:21:48 +0100
commitd57efb74bb6ad91b029fffff39ed4e482c41f8ba (patch)
tree761e445d321f7c85ad7a408dc4a0783f97714515 /daemons/ipa-sam/Makefile.am
parent9af8fa9dd59970a27630545b1fec32de5e100c51 (diff)
downloadfreeipa-d57efb74bb6ad91b029fffff39ed4e482c41f8ba.tar.gz
freeipa-d57efb74bb6ad91b029fffff39ed4e482c41f8ba.tar.xz
freeipa-d57efb74bb6ad91b029fffff39ed4e482c41f8ba.zip
Support Samba PASSDB 0.2.0 aka interface version 24
1. Samba project renamed libpdb to libsamba-passdb https://bugzilla.samba.org/show_bug.cgi?id=10355 2. With interface version 24, Samba removed uid_to_sid()/gid_to_sid() from the PASSDB interface and united them as id_to_sid(). Make sure FreeIPA ipa_sam code supports new and old versions of the PASSDB API. https://fedorahosted.org/freeipa/ticket/4778 Reviewed-By: Sumit Bose <sbose@redhat.com>
Diffstat (limited to 'daemons/ipa-sam/Makefile.am')
-rw-r--r--daemons/ipa-sam/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/daemons/ipa-sam/Makefile.am b/daemons/ipa-sam/Makefile.am
index d55a18770..46c813af5 100644
--- a/daemons/ipa-sam/Makefile.am
+++ b/daemons/ipa-sam/Makefile.am
@@ -1,7 +1,8 @@
NULL =
+LIBPDB_NAME = @LIBPDB_NAME@
SAMBA40EXTRA_LIBS = $(SAMBA40EXTRA_LIBPATH) \
-lsmbldap \
- -lpdb \
+ -l$(LIBPDB_NAME) \
-lsmbconf \
$(NULL)